Important: Update to GCIC Requirements
Incident Report for Asurint
Resolved
Update in place for 3+ months. Is now tracked as BAU.
Posted Feb 16, 2024 - 07:59 EST
Monitoring
As part of our continued commitment to be your trusted screening partner offering the highest level of compliance, we want to inform you effective today November 6th, there are several updates to the required authorization form for Georgia Crime Information Center (G.C.I.C). Most notably, the G.C.I.C. will not return records associated with alias names; rather, any matching results will only be returned for the submitted legal name.

Additional requirements are listed below:

• Race and Gender are now required fields: The form now includes race and gender options for the candidate to select including “unknown” and “prefer not to say”.

• Authorization period is required: Asurint has defaulted the authorization form to indicate a 90-day authorization period.

• Purpose Code: Asurint has defaulted the form to indicate “e” for employment purposes.

For clients enabled with Applicant Direct Portal, please use the following link for an example of the updated form. https://go.asurint.com/l/298262/2023-11-06/m1ndl5/298262/1699291361YE8m8uu3/GCIC_ADP_Example_Form_Completed.pdf

For clients using the G.C.I.C. form outside of the Applicant Direct Portal, please use the following link to view the updated form. https://go.asurint.com/l/298262/2023-11-06/m1ndlv/298262/1699291415mRtb0UTM/Master_GCIC_Consent.pdf

We are committed to making the necessary changes as seamless as possible to you and your business. Please do not hesitate to reach out if you have additional questions or concerns regarding these important changes at support@asurint.com or 1-800-906-1674.
Posted Nov 06, 2023 - 13:21 EST