Delays in Kentucky
Incident Report for Asurint
Resolved
This incident has been resolved.
Posted Jan 09, 2025 - 15:44 EST
Update
Turnaround times remain delayed. We are continuing to monitor the situation closely and will provide updates as they become available.
Posted Jan 08, 2025 - 17:00 EST
Monitoring
Due to the recent winter storm, all Kentucky counties are closed. A state of emergency has been declared by the Governor, and all state buildings will be closed on Monday, January 6th. This will not delay all orders, only orders where supplemental information is required by the court clerk.

We will continue to monitor the situation closely and provide updates as they become available.
Posted Jan 06, 2025 - 17:02 EST