Winter Storm Delays

Incident Report for Asurint

Resolved

This incident has been resolved.
Posted Jan 30, 2026 - 08:26 EST

Update

A severe winter storm continues to cause widespread court closures across the U.S. due to hazardous travel conditions, ice, snow, and power outages.

Please note:
- Only searches requiring in‑person court clerk validation are affected.
- Online systems for all listed locations remain operational.

The following courts are currently closed due to weather conditions:
- Arkansas: All counties closed
- District of Columbia: Courts closed
- Massachusetts: All counties closed
- Maryland: All counties closed
- Maine: All counties closed
- West Virginia: All counties closed
Posted Jan 26, 2026 - 15:45 EST

Monitoring

Please be advised that several regions are currently under severe weather alerts through the weekend. Significant snowfall may result in closures and cause delays into next week. We will continue to monitor the situation and provide updates.
Posted Jan 23, 2026 - 14:34 EST
This incident affected: Asurint | Background Screening Platform and Asurint | Tenant Screening Platform.