North Carolina access restrictions

Incident Report for Asurint

Resolved

Access has been restored. We are currently working through the impacted orders as quickly as possible.
Posted Sep 25, 2023 - 14:18 EDT

Investigating

Our access to the NC website is currently down. We have registered help desk tickets with their IT team and are waiting for an estimated time of resolution.
Posted Sep 22, 2023 - 14:33 EDT

Identified

North Carolina has restrictions in place to limit the number of users for their website which is creating delays in order completion. We are actively working to increase our access and expect to have a resolution in place the week on 9/25. That will allow us to address the backlog.
Posted Sep 22, 2023 - 09:49 EDT